Fix Logjam Vulnerability – Ubuntu – Apache

In the last few years we had the Heartbleed, Poodle attack and now we have Logjam witch is an attack there allow a man-in-the-middle attacker to downgrade vulnerable TLS connections to 512-bit export-grade.

Here is a few simple steps there will fix the vulnerability on you Lamp server.

We are going to createa directory for our ssl and give it the right permission

It is gonig to take a little time to generate so be patient.

Open ssl.conf with your favorite text editor

Add or edit these lines

 

And thats it, you should have closed then Logjam vulnerability on your server. you test it here to confirm it.